Ringcentral Issues

Major incident OHT Ringcentral Phones HPK Ringcentral Phones LKV Ringcentral Phones CMO Ringcentral Phones
Jan 22, 2025 14:44 CST · 18 hours, 9 minutes

Updates

Resolved

Ringcentral has notified us that they believe a fix is in place. If you notice issues please open a ticket with IT helpdesk.

January 23, 2025 · 08:53 CST
Issue

Ringcentral notified us that they are having issues with some customers including inbound and outbound calls. Some toll free inbound numbers such as 800-737-8110 are intermittent. We will continue to work with them.

January 22, 2025 · 14:44 CST

← Back