Email Delivery Delay

Minor incident QAD Supplemental Email Delivery
Jul 30, 2024 14:51 CDT · 17 hours, 13 minutes

Updates

Resolved

Vendor says this is resolved.

July 31, 2024 · 08:04 CDT
Issue

Our email vendor notified us that there may be delivery delays. They are investigating. This is mainly e-forms related such as PO, SO, Quotes, etc.

July 30, 2024 · 14:51 CDT

← Back