E-Forms Delays

Minor incident US QAD QAD Supplemental Email Delivery
May 01, 2024 08:20 CDT · 1 hour, 49 minutes

Updates

Resolved

Our vendor let us know this has been resolved. There may be some processing Microsoft needs to do in order to get caught up and into your inbox.

May 1, 2024 · 10:09 CDT
Investigating

The email vendor says they identified the issue, and emails should start flowing soon. This impacts scan to email, QAD emails for PO’s, etc.

May 1, 2024 · 09:11 CDT
Investigating

We were informed of delivery delays for PO’s and such to Email. The email delivery service is investigating.

May 1, 2024 · 08:20 CDT

← Back